Feature #2944

Allow to boot from unknown state on a different host (shared store)

Added by Hendrik Hasenbein over 5 years ago. Updated about 5 years ago.

Status:ClosedStart date:05/26/2014
Priority:HighDue date:
Assignee:-% Done:

0%

Category:Core & System
Target version:Release 4.10
Resolution:duplicate Pull request:

Description

It would be nice to be able to boot a virtual machine on another host if the original host is no longer available and onevm delete --recreate is no option.

While it is possible to recover from the unknown state as soon as the replacement host is up, it would be nice to be able to recover the VM to another host in the cluster which has exact the same view on the storage. For example "onevm boot --host <hostid>" or "onevm boot --newhost" (host autoselection via scheduler) would be really nice to have.


Related issues

Related to Feature #1639: VM Disaster Recovery without resubmit of harddisk images Closed 11/07/2012

History

#1 Updated by Hendrik Hasenbein over 5 years ago

should have been posted to request. please move.

#2 Updated by Ruben S. Montero over 5 years ago

  • Tracker changed from Feature to Backlog
  • Priority changed from Normal to High

Yes it make sense, moving it to backlog with high priority for a future release

#3 Updated by Ruben S. Montero about 5 years ago

  • Related to Feature #1639: VM Disaster Recovery without resubmit of harddisk images added

#4 Updated by Ruben S. Montero about 5 years ago

  • Tracker changed from Backlog to Feature
  • Status changed from Pending to Closed
  • Target version set to 67
  • Resolution set to duplicate

This is a duplicate of #1639. It has been implemented and available in the repo for 4.8.1

#5 Updated by Ruben S. Montero about 5 years ago

  • Target version changed from 67 to Release 4.10

Also available in: Atom PDF