Bug #3082

Ruby version on Centos 6 failures

Added by Jose Angel Diaz Diaz over 6 years ago. Updated over 6 years ago.

Status:ClosedStart date:07/22/2014
Priority:LowDue date:
Assignee:Jaime Melis% Done:

0%

Category:Core & System
Target version:Release 4.8
Resolution:fixed Pull request:
Affected Versions:Development

Description

I'm trying the new opennebula 4.7.80 dev version and i've found a problem with the ruby packages on Centos 6.

The package version at Centos repos for ruby is :  ruby-1.8.7.352-13.el6.x86_64

When we run the install_gems scripts this script try to install the sqlite3 adn azure but the minimal ruby version required is: Ruby version >= 1.9.2

I've solved this problem with RVM package and manual install of the last ruby version:

ruby --version
ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux]

curl -L get.rvm.io | bash -s stable
source /etc/profile.d/rvm.sh
rvm install 1.9.3

ruby --version
ruby 1.9.3p547 (2014-05-14 revision 45962) [x86_64-linux]

Now i can install the gems with the install script.

But the problem now is with the novnc-server, when we try to start it shows:

#service opennebula-novnc start
Starting Opennebula Novnc daemon: /usr/local/rvm/gems/ruby-1.9.3-p547/gems/json-1.8.1/lib/json/ext/parser.so: [BUG] Segmentation fault
ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux]

bash: línea 1: 1329 Abortado (`core' generado) /usr/bin/novnc-server start
[FALLÓ]

It's seems not compatible with my rvm ruby solution for this one...

Associated revisions

Revision 13e1f7fb
Added by Jaime Melis over 6 years ago

Bug #3082: Don't install gems that require Ruby > 1.9 if that Ruby version is not available

History

#1 Updated by Javi Fontan over 6 years ago

  • Assignee set to Javi Fontan
  • Target version set to Release 4.8

#2 Updated by Javi Fontan over 6 years ago

  • Assignee changed from Javi Fontan to Jaime Melis

#3 Updated by Jaime Melis over 6 years ago

We have fixed install_gems so it doesn't install gems that are not available for Ruby < 1.9 if that ruby version is not available.

The other problems seems to be a problem in the rvm installation:

Starting Opennebula Novnc daemon: /usr/local/rvm/gems/ruby-1.9.3-p547/gems/json-1.8.1/lib/json/ext/parser.so: [BUG]
Segmentation fault
ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux]

It's starting with 1.8.7 instead of >= 1.9

#4 Updated by Jaime Melis over 6 years ago

  • Assignee changed from Jaime Melis to Javi Fontan

Test with C7

#5 Updated by Ruben S. Montero over 6 years ago

  • Status changed from Pending to Closed
  • Assignee changed from Javi Fontan to Jaime Melis
  • Resolution set to fixed

Also available in: Atom PDF