Bug #3154

Selection of the template does not work

Added by Sergio Milanese about 6 years ago. Updated about 6 years ago.

Status:ClosedStart date:08/15/2014
Priority:HighDue date:
Assignee:Daniel Molina% Done:

90%

Category:Sunstone
Target version:Release 4.10
Resolution:fixed Pull request:
Affected Versions:OpenNebula 4.8

Description

Hello,
I have advanced the version from 4.6 to 4.8. In the visual vdcadmin and cloud
click on the template will not turn on and you can not create the vm.
4.6 works fine but 4.8 is broken.
Firefox 31 in Ubuntu 14.04


Related issues

Duplicated by Bug #3184: [cloud view] Can not select a template with RAW section Closed 09/11/2014

Associated revisions

Revision 91edfb68
Added by Daniel Molina about 6 years ago

bug #3154: Fix issues when the template contains single quotes

Revision 8f5be2f2
Added by Daniel Molina about 6 years ago

bug #3154: Fix issues when the template contains single quotes
(cherry picked from commit 91edfb688f6480f54aac1bf20a881436d2014d92)

Revision 40a1cc47
Added by Daniel Molina about 6 years ago

bug #3154: Fix issues when the template contains single quotes

History

#1 Updated by Sergio Milanese about 6 years ago

EDIT: It works with a fresh install on a vm test.

#2 Updated by Sergio Milanese about 6 years ago

Ok, the problem is the RAW content in all my template: RAW=[DATA="<devices><video><model type='vga'><acceleration accel3d='yes' accel2d='yes'/></model></video></devices>",TYPE="kvm"]

Vm deploy found with this RAW in admin and user view but in vdcadmin and cloud view not found...
Problem only in 4.8 version

#3 Updated by Sergio Milanese about 6 years ago

OK, i solve this problem! The problem is this character ' Change with " solve!
RAW=[DATA="<devices><video><model type="vga"><acceleration accel3d="yes" accel2d="yes"/></model></video></devices>",TYPE="kvm"]

#4 Updated by Ruben S. Montero about 6 years ago

  • Status changed from Pending to New

Thanks for the feedback, and for keeping the issue updated.

#5 Updated by Carlos González Vila about 6 years ago

I found the same problem. double quotes (") are replaced with " in the template selection page, but not single quotes (').

#6 Updated by Ruben S. Montero about 6 years ago

  • Target version set to 67

#7 Updated by Daniel Molina about 6 years ago

  • Status changed from New to Closed
  • Assignee set to Daniel Molina
  • % Done changed from 0 to 90
  • Resolution set to fixed

Thank you for your feedback, it should be fixed with the attached patch. It will be included in the next release

#8 Updated by Daniel Molina about 6 years ago

  • Duplicated by Bug #3184: [cloud view] Can not select a template with RAW section added

#9 Updated by Ruben S. Montero about 6 years ago

  • Target version changed from 67 to Release 4.10

Also available in: Atom PDF