Bug #320

VM stays in boot state when the hypervisor doesn't start properly

Added by Nuno Cardoso over 10 years ago. Updated over 10 years ago.

Status:ClosedStart date:08/19/2010
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:Release 1.4
Resolution:worksforme Pull request:
Affected Versions:

Description

When a VM is started and for some reason the hypervisor exits with an error, OpenNebula keeps it in boot state.
Two possible ways of reproducing this error are:
-Booting two machines with VNC in the same port
-Creating a VM with 1MB of RAM

History

#1 Updated by Ruben S. Montero over 10 years ago

  • Status changed from New to Closed
  • Resolution set to worksforme

I could not reproduce this issue. In my logs I get:

Sat Sep 4 15:18:50 2010 [VMM][I]: STDERR follows.
Sat Sep 4 15:18:50 2010 [VMM][I]: error: Failed to create domain from /home/ruben/Virtual/one/var//12/images/deployment.0
Sat Sep 4 15:18:50 2010 [VMM][I]: error: internal error process exited while connecting to monitor: inet_listen_opts: bind(ipv4,127.0.0.1,5902): Address already in use

The VM then proceeds to fail state.

Maybe there are other reasons for this. I am closing the issue, and will reopen if needed. THANKS for the feedback!

Also available in: Atom PDF