Feature #3223

Ability to change the IP/gateway/MAC/mask after the template is instantiated

Added by Mariano Guezuraga about 5 years ago. Updated about 5 years ago.

Status:ClosedStart date:10/03/2014
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:duplicate Pull request:

Description

We have a product here in our company that keeps tracks of IP leases and networks settings, so implementing the ONE network part seems a bit redundant.

I would like to have the possibility of skipping entirely the network component in ONE and do all the assignments by myself, or at least be able to modify the VM template on a hook


Related issues

Related to Feature #2545: Decorrelate networks TYPE and IP management Closed 12/08/2013

History

#1 Updated by Arnold Bechtoldt about 5 years ago

Good point. Today I had the same issue and took a look at the VNETs. In 4.8 you can skip IP address management when you add address ranges of type Ethernet instead of IPv4/IPv6.

That works really great with KVM/ libvirt interfaces on a Open vSwitch.

#2 Updated by Ruben S. Montero about 5 years ago

  • Status changed from Pending to Closed
  • Resolution set to duplicate

Yep it seems that the 4.8 network address this. I think this is a duplicate of #2545. We can reopen it if needed.

#3 Updated by Ruben S. Montero about 5 years ago

  • Related to Feature #2545: Decorrelate networks TYPE and IP management added

Also available in: Atom PDF