Bug #3849

Quotas in UserPool-XML don't match documented schema

Added by Michael Schmidt almost 6 years ago. Updated almost 6 years ago.

Status:ClosedStart date:06/23/2015
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Documentation
Target version:Release 4.14
Resolution:invalid Pull request:
Affected Versions:OpenNebula 4.12

Description

In a fresh installation of opennebula 4.10 or 4.12 (both versions are affected) on a clean debian wheezy installation, issuing 'oneuser list -x' yields the following output:

<USER_POOL>
  <USER>
    <ID>0</ID>
    <GID>0</GID>
    <GROUPS>
      <ID>0</ID>
    </GROUPS>
    <GNAME>oneadmin</GNAME>
    <NAME>oneadmin</NAME>
    <PASSWORD>fe05bcdcdc4928012781a5f1a2a77cbb5398e106</PASSWORD>
    <AUTH_DRIVER>core</AUTH_DRIVER>
    <ENABLED>1</ENABLED>
    <LOGIN_TOKEN/>
    <TEMPLATE>
      <TOKEN_PASSWORD><![CDATA[97fc29a2162405277a5d2a0ef33acfcbd4f78e4e]]></TOKEN_PASSWORD>
    </TEMPLATE>
  </USER>
  <QUOTAS>
    <ID>0</ID>
    <DATASTORE_QUOTA/>
    <NETWORK_QUOTA/>
    <VM_QUOTA/>
    <IMAGE_QUOTA/>
  </QUOTAS>
  <USER>
    <ID>1</ID>
    <GID>0</GID>
    <GROUPS>
      <ID>0</ID>
    </GROUPS>
    <GNAME>oneadmin</GNAME>
    <NAME>serveradmin</NAME>
    <PASSWORD>f9f3c8912fc6cc53012d743ded329c4f5fb035a5</PASSWORD>
    <AUTH_DRIVER>server_cipher</AUTH_DRIVER>
    <ENABLED>1</ENABLED>
    <LOGIN_TOKEN/>
    <TEMPLATE>
      <TOKEN_PASSWORD><![CDATA[d53363ad24f9f5b44a95d028c78f1a9d3320fdee]]></TOKEN_PASSWORD>
    </TEMPLATE>
  </USER>
  <QUOTAS>
    <ID>1</ID>
    <DATASTORE_QUOTA/>
    <NETWORK_QUOTA/>
    <VM_QUOTA/>
    <IMAGE_QUOTA/>
  </QUOTAS>
  <DEFAULT_USER_QUOTAS>
    <DATASTORE_QUOTA/>
    <NETWORK_QUOTA/>
    <VM_QUOTA/>
    <IMAGE_QUOTA/>
  </DEFAULT_USER_QUOTAS>
</USER_POOL>

As you can see, quotas are given in QUOTAS and DEFAULT_USER_QUOTAS structures which are on the same level as the USER elements. In contrast, according to the documentation DEFAULT_USER_QUOTAS should be a child of the USER element and the children of the QUOTAS element should be direct children of the USER element.

History

#1 Updated by Ruben S. Montero almost 6 years ago

  • Category set to Documentation
  • Target version set to Release 4.14

Thanks for the heads up

#2 Updated by Carlos Martín almost 6 years ago

  • Status changed from Pending to Closed
  • Resolution set to invalid

Hi,

The User and User Pool xsd schemas are different: http://docs.opennebula.org/4.12/integration/system_interfaces/api.html#schemas-for-user
For some pools the XML returned by the .info and *pool.info calls are not exactly the same.

Thanks for the feedback anyway.

Also available in: Atom PDF