Bug #5069

Ceph driver removes data in system datastore when using shared system datastore

Added by kvaps kvaps over 3 years ago. Updated over 3 years ago.

Status:ClosedStart date:03/20/2017
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Drivers - Storage
Target version:Release 5.4
Resolution:invalid Pull request:
Affected Versions:OpenNebula 5.2

Description

I use ceph images datastore, and shared filesystem (non ceph) system datastore.

ceph tm configuration:

TM_MAD_CONF = [
NAME = "ceph", LN_TARGET = "NONE", CLONE_TARGET = "SELF", SHARED = "YES",
DS_MIGRATE = "NO"
]

If I start migrate vm to other server, ceph tm driver removes any vm data in system datastore.

I fixed it in #4969 but I think this problem may be actually after appling my changes if non ceph system datastore will be used.


Related issues

Related to Feature #5061: Option to override TM_MAD's SHARED=[YES/NO] per datastore New 03/14/2017

History

#1 Updated by Ruben S. Montero over 3 years ago

  • Category set to Drivers - Storage
  • Status changed from Pending to New
  • Target version set to Release 5.4

#2 Updated by Ruben S. Montero over 3 years ago

  • Related to Feature #5061: Option to override TM_MAD's SHARED=[YES/NO] per datastore added

#3 Updated by Vlastimil Holer over 3 years ago

  • Status changed from New to Closed
  • Resolution set to invalid

Hello,

kvaps kvaps wrote:

If I start migrate vm to other server, ceph tm driver removes any vm data in system datastore.
I fixed it in #4969 but I think this problem may be actually after appling my changes if non ceph system datastore will be used.

because this bug extends your previous #4969 and the originally reported problem was fixed in ticket #4924, I'm going to close this one as invalid.

Thank you for the report.

Best regards,
Vlastimil Holer

Also available in: Atom PDF