Bug #5119

Quota error when exceeding virtual network reservations

Added by kvaps kvaps over 3 years ago. Updated about 3 years ago.

Status:ClosedStart date:04/21/2017
Priority:NormalDue date:
Assignee:Juan Jose Montiel Cano% Done:

0%

Category:Core & System
Target version:Release 5.4.2
Resolution:fixed Pull request:
Affected Versions:OpenNebula 5.0, OpenNebula 5.2

Description

Steps to reproduce:

- Create network with ip addresses
- Set default quota for this network
- Logon as user in sunstone and go to the network
- Click Reserve button and create reservation for number of ip addresses exceeding the established quota
- It returns error, but empty network will be created:

[VirtualNetworkReserve] User [178] : user [178] limit of 10 reached for LEASES quota in NETWORK with ID: 3.

- Removing this network returns next messages, but network will be deleted:

[VirtualNetworkDelete] Cannot delete virtual network. Network ID is not part of the cluster set.
[VirtualNetworkInfo] Error getting virtual network [13].

- Now if you try to reserve 1 or more ip's you can't do this, because it returns the error:

[VirtualNetworkReserve] User [178] : user [178] limit of 10 reached for LEASES quota in NETWORK with ID: 3.

Associated revisions

Revision 0b36571b
Added by Juan Jose Montiel Cano about 3 years ago

B #5119: Removed vnet if user can not reserve (#493)

Revision 55908c1b
Added by Juan Jose Montiel Cano about 3 years ago

B #5119: Removed vnet if user can not reserve (#493)

(cherry picked from commit 0b36571b23259e089764c05127d4288c9e69be3b)

History

#1 Updated by Juan Jose Montiel Cano about 3 years ago

  • Category set to Core & System
  • Assignee set to Juan Jose Montiel Cano
  • Target version set to Release 5.6
  • Resolution set to fixed

#2 Updated by Ruben S. Montero about 3 years ago

  • Target version changed from Release 5.6 to Release 5.4.2

#3 Updated by Ruben S. Montero about 3 years ago

  • Status changed from Pending to Closed

Also available in: Atom PDF