Bug #5121

OneFlow-server not support run separated of main server

Added by kvaps kvaps almost 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:04/21/2017
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:OneFlow
Target version:-
Resolution:worksforme Pull request:
Affected Versions:OpenNebula 5.2

Description

Part of `oneflow-server.conf`:

:one_xmlrpc: http://opennebula:2633/RPC2

But sunstone report this error:

Failed to open TCP connection to localhost:2633 (Connection refused - connect(2) for "localhost" port 2633)

Very-very dirty workaround is changing ip address of localhost in /etc/hosts file from 127.0.0.1 to opennebula's ip, works fine.

History

#1 Updated by Ruben S. Montero almost 4 years ago

  • Status changed from Pending to Closed
  • Resolution set to worksforme

I cannot reproduce it. Could you double check (i.e. restart the oneflow server)?

Also available in: Atom PDF