Bug #65

Empty transfer files causes transfer manager to fail

Added by Redmine Admin over 12 years ago. Updated over 12 years ago.

Status:ClosedStart date:
Priority:HighDue date:
Assignee:Javi Fontan% Done:


Category:Drivers - Auth
Target version:Release 1.2
Resolution:fixed Pull request:
Affected Versions:


In case of an empty transfer file, virtual machines fail to be deployed. This is common if using ONE to manage instances on EC2.

The attached patch fixes it. Mind you, I've never touched a ruby script before, so I'm not sure if it's the proper "ruby way".

emtpy_transfer_file.patch Magnifier (585 Bytes) Redmine Admin, 01/17/2009 03:37 PM

emtpy_transfer_file.2.patch Magnifier - A version of the patch that actually does what it's supposed to.. (586 Bytes) Redmine Admin, 01/17/2009 04:04 PM

Associated revisions

Revision dce65cfd
Added by Javi Fontan over 12 years ago

Solved ticket #65. Patch submited by Soren Hansen

git-svn-id: http://svn.opennebula.org/one/trunk@306 3034c82b-c49b-4eb3-8279-a7acafdc01c0

Revision 066d18a7
Added by Ruben S. Montero over 12 years ago

backport of changsets [306] [307] [308] [309], tickets #65 #59 #67

git-svn-id: http://svn.opennebula.org/one/branches/one-1.2@315 3034c82b-c49b-4eb3-8279-a7acafdc01c0

Revision a2accf86
Added by Ruben S. Montero over 12 years ago

backport of changeset [306], ticket #65

git-svn-id: http://svn.opennebula.org/one/branches/one-1.2@316 3034c82b-c49b-4eb3-8279-a7acafdc01c0


#1 Updated by Redmine Admin over 12 years ago

Sorry again :) This is clearly not an client library or API bug, but I don't see how to change the component after the bug is filed?

#2 Updated by Javi Fontan over 12 years ago

  • Resolution set to fixed

Solved in r306. Thanks a lot for the patch.

Also available in: Atom PDF