Bug #1158

ubuntu 10.04 installation fails - impossible to authenticate

Added by nicolas diogo over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:03/06/2012
Priority:NormalDue date:
Assignee:-% Done:


Target version:Release 3.4
Resolution:worksforme Pull request:
Affected Versions:OpenNebula 3.2



i have installed opennebula on a fresh ubuntu install x86_64 as per instructions.

followed instructions published here:

in addition to opennebula i have also installed the following packages:

apt-get install libsqlite0-dev mysql-client curl libxml2-dev libxslt1-dev ruby-dev libexpat1-dev
apt-get install qemu-kvm libvirt-bin

but when i try to check if the system is installed correctly i get the following error:

su - oneadmin -c "onevm list"
[VirtualMachinePoolInfo] User couldn't be authenticated, aborting call.

looking trough the logs i found some errors messages.

$ tail f /var/log/one/oneacctd.log
/usr/lib/one/ruby/acct/watch_helper.rb:18:in `require': no such file to load -
sequel (LoadError)
from /usr/lib/one/ruby/acct/watch_helper.rb:18
from /usr/lib/one/ruby/acct/acctd.rb:35:in `require'
from /usr/lib/one/ruby/acct/acctd.rb:35

so it seems that i have to install library package:

tried restarting oneacctd
but it posted on its log:

Error: [VirtualMachinePoolInfo] User couldn't be authenticated, aborting call.
Shutting down

as it seems to be a problem with the authentication - i have checked files available in $HOME/.one/ (/var/lib/one/.one) are listed below:

cd $HOME
for f in $(ls .one ) ;do echo "cat .one/"$f " " $(cat .one/$f) ; done
cat .one/ec2_auth serveradmin:d3e95acd9b1f5bc2e7766a0877a45882d483e007
cat .one/occi_auth serveradmin:d3e95acd9b1f5bc2e7766a0877a45882d483e007
cat .one/one_auth oneadmin:d3e95acd9b1f5bc2e7766a0877a45882d483e007
cat .one/sunstone_auth serveradmin:d3e95acd9b1f5bc2e7766a0877a45882d483e007

i have also tried to change the password from SHA hash to plain text in all files but it did not work at all.
and the oneacctd.log shows the same error message.

i am not sure if it is a problem with the documentation or the package built, but definitely there is something that is not working as expected.

i am trying to highlight something that may need some attention - which was missed by your quality control.

thanks a lot.



#1 Updated by olivier sallou over 9 years ago

oneacctd is for accounting, you should first fix issue with "onevm list"
password in .one/one_auth must be in clear text so try logging as oneadmin user and execute "onevm list" with your clear password set in the file.

#2 Updated by Ruben S. Montero over 9 years ago

  • Target version set to Release 3.4

#3 Updated by Jaime Melis over 9 years ago

  • Status changed from New to Closed
  • Resolution set to worksforme

We have reviewed the ubuntu package and it works as expected.

After installation oned is running and onevm list is working without changing the password or setting ONE_AUTH.

Also available in: Atom PDF