Bug #1161

toggle volume persistence fails in sunstone

Added by Jan Horacek over 9 years ago. Updated about 9 years ago.

Status:ClosedStart date:03/08/2012
Priority:NormalDue date:
Assignee:Hector Sanjuan% Done:

100%

Category:Sunstone
Target version:Release 3.4
Resolution:fixed Pull request:
Affected Versions:OpenNebula 3.2

Description

clicking on the checkbox in sunstone to change persistence state fails - it looks like it has problem when submitting the volume id...

volume:
28 oneadmin oneadmin ttylinux-persistent

clicking on "persistent" checkbox returns errors:

×
Error
method ImageInfo
action Show
object image
id 2
×
Error
method ImageInfo
action Show
object image
id 8

it looks like problem with multi-digit id's

switching persistence with oneimage command line tool works OK.

Associated revisions

Revision c62c2d02
Added by Hector Sanjuan over 9 years ago

Bug #1161: Wrong calls to Image.[non]persistent

Persistency actions are of type "multiple", therefore they expect an array of elements. As only the ID string was passed, action was iterated for all the chars in the ID.

Revision 77355a68
Added by Hector Sanjuan over 9 years ago

Bug #1161: Wrong calls to Image.[non]persistent

Persistency actions are of type "multiple", therefore they expect an array of elements. As only the ID string was passed, action was iterated for all the chars in the ID.
(cherry picked from commit c62c2d02972d268ed154e4ac655ad094a6076c83)

Revision 2551eecc
Added by Hector Sanjuan over 9 years ago

Bug #1161: Wrong calls to Image.[non]persistent

Persistency actions are of type "multiple", therefore they expect an array of elements. As only the ID string was passed, action was iterated for all the chars in the ID.
(cherry picked from commit c62c2d02972d268ed154e4ac655ad094a6076c83)

History

#1 Updated by Ruben S. Montero over 9 years ago

  • Category set to Sunstone
  • Target version set to Release 3.4

#2 Updated by Hector Sanjuan over 9 years ago

  • Assignee set to Hector Sanjuan

#3 Updated by Hector Sanjuan over 9 years ago

  • Status changed from New to Assigned

hello,

i cannot reproduce this

#4 Updated by Hector Sanjuan over 9 years ago

  • % Done changed from 0 to 100
  • Resolution set to fixed

Ups my previous comment shouldn't have been sent. Actually I could reproduce it very well. It's now been fixed on the 3.2 and master branches. Thanks for the report!

#5 Updated by Hector Sanjuan over 9 years ago

  • Status changed from Assigned to Closed

Also available in: Atom PDF