Bug #1263

install_novnc fails due to SSL certificate

Added by olivier sallou over 7 years ago. Updated over 6 years ago.

Status:ClosedStart date:05/04/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Sunstone
Target version:-
Resolution: Pull request:
Affected Versions:OpenNebula 3.4

Description

After upgrade to one 3.4 with Debian package, VNC via Sunstone failed.

I had to reinstall novnc with the install_novnc.sh script.
First issue is it should have been installed with package.

Second issue is script fail to download due to curl SSL certificate:
Downloading noVNC latest version...
0,0%
curl: (60) SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
More details here: http://curl.haxx.se/docs/sslcerts.html
....

I had to add -k option to curl command to get it work.

History

#1 Updated by Hector Sanjuan over 7 years ago

  • Category set to Sunstone

Hello,

It seems the problem appears now because wget was replaced with curl in 3.4.

Still I think the problem is not in the script but in curl and your distro. Apparently curl is unable to find an appropiate CA to verify that the SSL connection to github is legit. Bypassing SSL verification by default with -k in all cases is not a good solution.

Also, it is not so easy to do an integration of a package-intalled version of noVNC that works for all distros (some don't have such package, others are too old), but thanks for the suggestion. We will keep an eye on the possibility as novnc becomes more stable and mature.

#2 Updated by Ruben S. Montero over 6 years ago

  • Status changed from New to Closed

Also available in: Atom PDF