Feature #132

Support for Reboot action

Added by Ruben S. Montero over 11 years ago. Updated almost 9 years ago.

Status:ClosedStart date:08/11/2009
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Core & System
Target version:Release 3.2
Resolution:fixed Pull request:

Description

Most hypervisors include a reboot option, OpenNebula can easily include a new reboot command for the onevm tool. The reboot action would be performed in the RUNNING state.

This issue includes:
  • Support in the core for reboot
  • Extend the OpenNebula Cloud API for the new action
  • Implement a new reboot command in onevm
  • Implement the reboot call in the virtualization drivers
    • Xen
    • Libvirt/KVM
    • Vmware
  • Update command reference

Related issues

Related to Feature #1055: Reboot vs Reset Closed 01/09/2012
Duplicated by Feature #654: Reboot action for VMs Closed 05/19/2011

Associated revisions

Revision 7301def9
Added by Ruben S. Montero almost 9 years ago

feature #132: Support for reboot action in OpenNebula core

Revision 0d210130
Added by Ruben S. Montero almost 9 years ago

feature #132: Support for reboot action in base drivers

Revision a6592d09
Added by Ruben S. Montero almost 9 years ago

feature #132: Support for reboot in EC2 hybrid driver

Revision bb123d25
Added by Ruben S. Montero almost 9 years ago

feature #132: Support reboot in dummy drivers

Revision 157c3640
Added by Ruben S. Montero almost 9 years ago

feature #132: Generic support for reboot in locally executed drivers

Revision 31094d4c
Added by Ruben S. Montero almost 9 years ago

feature #132: Reboot for KVM

Revision 6713600f
Added by Ruben S. Montero almost 9 years ago

feature #132: Reboot for the Xen hypervisor

Revision eafea8ed
Added by Ruben S. Montero almost 9 years ago

feature #132, #1020: Reboot for VMWare Hypervisor

Revision 05a52847
Added by Ruben S. Montero almost 9 years ago

feature #132: Reboot method for OCA (Ruby bindings). Add reboot command for onevm tool

Revision 39cd73f4
Added by Ruben S. Montero almost 9 years ago

feature #132: Adds reboot to VM JSON class

Revision 1f3b50ba
Added by Ruben S. Montero almost 9 years ago

feature #132: Reboot for OCA (Java Bindings)

Revision 4f242f4d
Added by Ruben S. Montero almost 9 years ago

feature #132: Use again deploy_id from drv_message for actions.

Revision a5996c51
Added by Ruben S. Montero almost 9 years ago

feature #132: Use again deploy_id from drv_message for actions.
(cherry picked from commit 4f242f4df9ec31b1668abde9c41b96010a024205)

Revision adbf9dab
Added by Hector Sanjuan almost 9 years ago

Feature #132: Add reboot action to Sunstone

Revision 4b812d17
Added by Hector Sanjuan almost 9 years ago

Feature #132: Add reboot action to Sunstone
(cherry picked from commit adbf9dabc50a6854ebcf30f42b112a84c1aff8a7)

Revision facf641d
Added by Hector Sanjuan almost 9 years ago

Feature #132: Add reboot action to Sunstone

Revision b43bc21b
Added by Javi Fontan about 4 years ago

Merge pull request #132 from winem/issue-4882

regex match from the beginning to the end of the string in nic_deacti…

Revision 203dd521
Added by Javi Fontan about 4 years ago

Merge pull request #132 from winem/issue-4882

regex match from the beginning to the end of the string in nic_deacti…

History

#1 Updated by Ruben S. Montero over 11 years ago

  • Status changed from Assigned to New
  • Assignee deleted (Ruben S. Montero)
  • Target version changed from Release 1.4 to Release 1.4.2

#2 Updated by Ruben S. Montero over 10 years ago

  • Target version changed from Release 1.4.2 to Release 2.0

#3 Updated by Daniel Molina about 10 years ago

  • Target version deleted (Release 2.0)

#4 Updated by Ruben S. Montero over 9 years ago

  • Target version set to Release 3.0

#5 Updated by Ruben S. Montero about 9 years ago

  • Target version deleted (Release 3.0)

#6 Updated by Ruben S. Montero about 9 years ago

  • Target version set to Release 3.4

#7 Updated by Łukasz Oleś almost 9 years ago

As I see in commits there is only support for soft reboot which is not as useful as hard reboot.
If soft reboot is possible it means that I can still login into VM and reboot it manualy. The problem is when VM hangs(and it happens sometimes). There is no way to recover in ONE

#8 Updated by Ruben S. Montero almost 9 years ago

Hi Łukasz,

Yes you are right in your comments. I will close this one (as it targets reboot). I've open a new one #1055 to either re-implement the reboot action or include a new reset action.

THANKS for your feedback :)

Łukasz Oleś wrote:

As I see in commits there is only support for soft reboot which is not as useful as hard reboot.
If soft reboot is possible it means that I can still login into VM and reboot it manualy. The problem is when VM hangs(and it happens sometimes). There is no way to recover in ONE

#9 Updated by Ruben S. Montero almost 9 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

Merged and ready in master for Xen, KVM and VMware

#10 Updated by Ruben S. Montero almost 9 years ago

  • Target version changed from Release 3.4 to Release 3.2

Also available in: Atom PDF